iis选择.net版本 win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法 - IIS - 服务器之家

服务器之家

专注于服务器技术!
当前位置:首页 > Web服务器 > IIS

iis选择.net版本 win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法

发布时间:2017-03-26 来源:服务器之家

Windows 2012系统天然就支持 4.5框架,就像Windows 2008系统默认支持 3.5一样。我们也可以在2012系统中安装3.5框架,让IIS同时支持 2.0/3.5/4.0/4.5多个版本。

注意,这里提到的四个.NET框架版本,其实已经合并为两个。 3.5是.NET 2.0的升级版本, 4.5是.NET 4.0的升级版本。也就是说,当我们需要2.0版本时,把.NET框架调整到3.5即可;同理,当我们需要4.0版本时,把.NET框架调整到4.5即可。

安装准备

本文是以IIS 8.0为例,也适用于IIS 7.0/7.5/8.5版本,但不适用IIS 6.0版本,6.0版本对.NET框架的支持与设置和以后版本有很大区别。我们在安装IIS 8.0的时候,需确保已安装以下应用程序开发模块。